$re = '/[^\d\p{L}.,\s]+/u';
$str = 'L\'élève s\'est cassé la figure!
Il faut appeler le numéro 118 en cas d\'accident.
#drop-some-chars';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;