# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b/$1 DAY $2:$3:$4/gm;t' <<< "P0DT0H4M13S
P431DT19H4M13S
"