use strict;
my $str = 'P0DT0H4M13S
P431DT19H4M13S
';
my $regex = qr/^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b/mp;
my $subst = '$1 DAY $2:$3:$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";