package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b`)
var str = `P0DT0H4M13S
P431DT19H4M13S
`
var substitution = "$1 DAY $2:$3:$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}