import Foundation
let pattern = #"^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
P0DT0H4M13S
P431DT19H4M13S
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 DAY $2:$3:$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)