using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b";
string substitution = @"$1 DAY $2:$3:$4";
string input = @"P0DT0H4M13S
P431DT19H4M13S
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}