# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b"
test_str = ("P0DT0H4M13S\n"
"P431DT19H4M13S\n")
subst = "$1 DAY $2:$3:$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.