re = /^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b/m
str = 'P0DT0H4M13S
P431DT19H4M13S
'
subst = '$1 DAY $2:$3:$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result