#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b"
Local $sString = "P0DT0H4M13S" & @CRLF & _
"P431DT19H4M13S" & @CRLF & _
""
Local $sSubst = "$1 DAY $2:$3:$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)