const regex = /^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.(?:([1-9]*)|0)DT(\\d+)H(\\d+)M(\\d+)S\\b', 'gm')
const str = `P0DT0H4M13S
P431DT19H4M13S
`;
const subst = `$1 DAY $2:$3:$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);