// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.(?:([1-9]*)|0)DT(\d+)H(\d+)M(\d+)S\b").unwrap();
let string = "P0DT0H4M13S
P431DT19H4M13S
";
let substitution = "$1 DAY $2:$3:$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}