# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\/\/\S+\/([^\s\/]+\.pdf)$/replacement $1/gm;t' <<< "http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf"