use strict;
my $str = 'http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf';
my $regex = qr`https?://\S+/([^\s/]+\.pdf)$`mp;
my $subst = 'replacement $1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";