using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://\S+/([^\s/]+\.pdf)$";
string substitution = @"replacement $1";
string input = @"http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}