import Foundation
let pattern = #"https?://\S+/([^\s/]+\.pdf)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"replacement $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)