const regex = new RegExp('https?://\\S+/([^\\s/]+\\.pdf)$', 'gm')
const str = `http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf`;
const subst = `replacement $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);