#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?://\S+/([^\s/]+\.pdf)$"
Local $sString = "http://www.oldsite.com.au/*.pdf" & @CRLF & _
"https://www.newsite.com/wp-content/uploads/2021/01/*.pdf" & @CRLF & _
"http://www.test.com/a.b.c.pdf"
Local $sSubst = "replacement $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)