// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?://\S+/([^\s/]+\.pdf)$").unwrap();
let string = "http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf";
let substitution = "replacement $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}