package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://\S+/([^\s/]+\.pdf)$`)
var str = `http://www.oldsite.com.au/*.pdf
https://www.newsite.com/wp-content/uploads/2021/01/*.pdf
http://www.test.com/a.b.c.pdf`
var substitution = "replacement $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}