# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\R*$/•/u;t' <<< "~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
"