use strict;
my $str = '~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
';
my $regex = qr/\R*$/up;
my $subst = '•';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";