using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R*$";
string substitution = @"•";
string input = @"~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}