import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\R*$";
final String string = "~~~ CASE2 ~~~\n"
+ "line 1\n"
+ "line 2\n"
+ "line 3 with MULTIPLE LF\n\n\n\n";
final String subst = "•";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}