# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\R*$"
test_str = ("~~~ CASE2 ~~~\n"
"line 1\n"
"line 2\n"
"line 3 with MULTIPLE LF\n\n\n\n")
subst = "•"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.