// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)\R*$").unwrap();
let string = "~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
";
let substitution = "•";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}