re = /\R*$/
str = '~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
'
subst = '•'
result = str.sub(re, subst)
# Print the result of the substitution
puts result