const regex = /\R*$/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\R*$', 'u')
const str = `~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
`;
const subst = `•`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);