package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\R*$`)
var str = []byte(`~~~ CASE2 ~~~
line 1
line 2
line 3 with MULTIPLE LF
`)
var substitution = []byte("•")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}