# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)//g;t' <<< "H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e"