use strict;
my $str = 'H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e';
my $regex = qr/((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";