using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)";
string substitution = @"";
string input = @"H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}