import Foundation
let pattern = #"((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)