const regex = /((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\w;)+\\w)\\n-{3,}\\n((?1)\\n)+(?1)', 'g')
const str = `H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);