# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)"
test_str = ("H;e;l;a;a\n"
"---------\n"
"J;a;c;k;p\n"
"c;d;e;d;c\n"
"f;d;e;c;d\n"
"k;d;c;d;s\n"
"d;e;f;d;e")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.