import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\w;)+\\w)\\n-{3,}\\n((?1)\\n)+(?1)";
final String string = "H;e;l;a;a\n"
+ "---------\n"
+ "J;a;c;k;p\n"
+ "c;d;e;d;c\n"
+ "f;d;e;c;d\n"
+ "k;d;c;d;s\n"
+ "d;e;f;d;e";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}