// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)").unwrap();
let string = "H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}