package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)`)
var str = `H;e;l;a;a
---------
J;a;c;k;p
c;d;e;d;c
f;d;e;c;d
k;d;c;d;s
d;e;f;d;e`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}