#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((\w;)+\w)\n-{3,}\n((?1)\n)+(?1)"
Local $sString = "H;e;l;a;a" & @CRLF & _
"---------" & @CRLF & _
"J;a;c;k;p" & @CRLF & _
"c;d;e;d;c" & @CRLF & _
"f;d;e;c;d" & @CRLF & _
"k;d;c;d;s" & @CRLF & _
"d;e;f;d;e"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)