# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\t| {4})+)/\n\1/g;t' <<< "def calc_value(a, b, c): if a>b+c: return a else: return b"