re = /((?:\t| {4})+)/
str = 'def calc_value(a, b, c): if a>b+c: return a else: return b'
subst = '\\n\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result