#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:\t| {4})+)"
Local $sString = "def calc_value(a, b, c): if a>b+c: return a else: return b"
Local $sSubst = "\n\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)