import Foundation
let pattern = #"((?:\t| {4})+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"def calc_value(a, b, c): if a>b+c: return a else: return b"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)