import re
regex = re.compile(r"((?:\t| {4})+)")
test_str = "def calc_value(a, b, c): if a>b+c: return a else: return b"
subst = "\\n\\1"
result = regex.sub(subst, test_str)
if result:
print(result)