const regex = new RegExp('((?:\\t| {4})+)', 'g')
const str = `def calc_value(a, b, c): if a>b+c: return a else: return b`;
const subst = `\n\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);