use strict;
my $str = 'def calc_value(a, b, c): if a>b+c: return a else: return b';
my $regex = qr/((?:\t| {4})+)/p;
my $subst = '\\n\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";