using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\t| {4})+)";
string substitution = @"\n\1";
string input = @"def calc_value(a, b, c): if a>b+c: return a else: return b";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}