# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^"]$/$0"/gm;t' <<< "1,A,\"apple\"
2,B,\"banana\"
3,C,\"cherry
4,D,\"durian\"
5,E,\"elderberry
6,F,\"Fanta™\"
7,G,\"grape
8,H,\"honeydew\""