# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\"]$"
test_str = ("1,A,\"apple\"\n"
"2,B,\"banana\"\n"
"3,C,\"cherry\n"
"4,D,\"durian\"\n"
"5,E,\"elderberry\n"
"6,F,\"Fanta™\"\n"
"7,G,\"grape\n"
"8,H,\"honeydew\"")
subst = "$0\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.