re = /[^"]$/m
str = '1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"'
subst = '$0"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result