import Foundation
let pattern = #"[^"]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)